Polaris Riders Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Has anyone noticed that the trans in their Predator seems unusually clunky? It seems like the clutch must be pulled all the way in and even still it is a little rough. I mostly notice it while drag racing, but it is always there. I have been treating it very nice too since it is new. Full Clutch, completely let off the gas between shifts. It is noticable while down shifting too. I hopped on my girlfriends 400EX just for comparison and it is a smooth as silk.

Thanks, Phill.
 

·
Mostly Harmless
Joined
·
2,544 Posts
How many hours are on your machine? Mine was kinda clunky initially but now I have 60+ hours on it and it's every bit as smooth as my old 400EX.

Rob
 

·
Registered
Joined
·
232 Posts
I don't know if I've just adjusted the way I ride the predator or if the noise just goes away overtime but it died down for me.
Hopefully it will do the same for you.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
I just got it last Friday. I did the proper break-in, rode it easy for a little while after I changed the oil. Then I let it have it. It has only about 3-4 hours on it.

- Phill -
 

·
Registered
Joined
·
429 Posts
Mine is clunky as well (3-4 hrs), but the consensus of everyone I've talked to is that it will improve and that's just the way it is.
 

·
Premium Member
Joined
·
383 Posts
mine was clunky when I first got it. I had my dealer call Polaris because I was paranoid that something was wrong. Polaris stated to my dealer that it is just the way this bike is. They say it is just a noisy trans. I have noticed that mine is not so loud any more. I have probably close to 30-40 hours on it.
 
1 - 6 of 6 Posts
Top