Polaris Riders Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
68 Posts
Hey Meyerz, Ive sent you a PM about where you ride at.....where did you get your bike at? and where in Dubuque do you live?
 

·
Premium Member
Joined
·
1,055 Posts
Hey meyerz your already replacing the packing?
 

·
Registered
Joined
·
118 Posts
Discussion Starter · #4 ·
I just wondering if anyone has done the repacking yet? I have not done it. I remember the instructions saying a time line but I think it's every 100 hours. Fred55 I have not recieved the pm.
 

·
Premium Member
Joined
·
1,055 Posts
Oh okay gothca. Does the 100 hrs. apply for all silencers in general?
 

·
Registered
Joined
·
1,744 Posts
i just pulled my instructions out for my pipe (the e-series/pure polaris). It says polaris recomends repacking after every 10-12 hours! i have about 50 hours on mine and have not repacked it yet, and dont plan to till probably this winter!
 

·
Registered
Joined
·
993 Posts
You must be a lucky one, my pure polaris slip-on didn't come with any instructions at all. I had to look here to find out what the extra piece (the quiet disk) was.
 

·
Mostly Harmless
Joined
·
2,544 Posts
Why exactly do you need to repack them? And do you have to use new packing (guessing you do)? And where do you get the new packing? And so on, and so on, and so on...:)

Rob
 

·
Registered
Joined
·
453 Posts
Keeping them properly packed keeps the noise down and they work at their highest efficiency. You can buy the high dollar packing material from the pipe makers or use fiberglass house insulation. The harder you run the machine the sooner it will burn/blow out...
 

·
Registered
Joined
·
1,744 Posts
yeah what powerslider said. the packing burns out and when it does your not getting the proper back pressure and then bad things can happen over time, like valve wear! when i bought my 400ex used the guy was running stock muffler with no baffle whick meant no back pressure. the valves were **** after about 6 months and i put an e-series on when i got it. dealer said this was do to being run with stock pipe and no baffle!
 
1 - 10 of 10 Posts
Top