Polaris Riders Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
242 Posts
Discussion Starter #1
Ok i have had my predator for about 1 month and 2 weeks now and for like the first 3 weeks that i had it every thing was fine like when i started it up vroom it was right up now when i start it up even on a full tank of gas its like clak clak clak vroom.... and then its good any reason why its doing this
?
 

·
Premium Member
Joined
·
1,055 Posts
I like the sound effects:) What exactly is clacking though? engine? chain?
 

·
Registered
Joined
·
103 Posts
lol ! clack clack vroom.. from that sound effect right there I can tell you, your doppleganger is going bad.
 

·
Registered
Joined
·
242 Posts
Discussion Starter #4
ok what really is that doppleganger ? ...... this is happening on a full tank of gas and i want to get this fixed be4 i go out again ..... so if you can let me know how i can fix it i will perciate it very much
 

·
Registered
Joined
·
46 Posts
It sounds to me like your weather has warmed up and your jetting is effected. When starting; try holding the throttle on just a tad. Now does it start right up? Try not to use the choke at all. The clacking you hear is most likely the valve train in slow motion as the starter is trying to turn it over. When it starts; the clacking turns into a beautiful Polaris symphony. Correct?
 

·
Registered
Joined
·
242 Posts
Discussion Starter #6
let me go check that out now .... ill get back to you on that
 

·
Registered
Joined
·
242 Posts
Discussion Starter #7
alright that did the trick but i got to do that ever time i guess but is there any other reason why its not turning over ...... i like to check it to make sure everything is a 100% or close to it for when i go out ...
 
1 - 9 of 9 Posts
Top