Polaris Riders Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
235 Posts
Discussion Starter · #1 ·
I have a question for all those in Predator land. My son and I were riding our preds yesterday and mine ran fine. But when we were racing down the pavement at the end my sons just stalled and wouldn't start. I checked everythign I could and it appeared ir was getting no gas. Funny things was for 2 times it woudl start and idle real fast with the choke out all the way. But only twice then same just turned over. I checked the air flow and it was good. I checked the fuel lever and it was to the ON position, I also tried to put it to reserver position but still wouldn't start. We checked the gas tank and there was plenty of gas. So we towed it back to the trailer and were going to load it up but I thought I would try one last time to start it. It turned over for a few seconds then started and ran like normal. Very strange, little paraniod to go riding with it now. Any Ideas?
 

·
Registered
Joined
·
37 Posts
Maybe the cable between the carb and the thumb switch is kinked or something mine i had to loosen up after i pinched it while changeing the plug.
 

·
Registered
Joined
·
235 Posts
Discussion Starter · #4 ·
It turned over just fine so not the battery. Could of been a pinched cable I guess, very strange now runs ok.
 

·
Registered
Joined
·
141 Posts
Might want to make sure it's not the ETC. If there is too much play in the throttle the contacts will touch and the machine will not run. It will kill it when you let off the throttle and won't let it start unless you give it a little throttle forcing the contacts apart.

Make sure the wires are still where they belong in the harness too. Mine didn't have much plastic in between the contacts in the connector it's self but that might have been my fault while trying to repair it after a non Polaris owner tried to "Bypass" the safty feature a few months back. :(

Good luck and please let us know if it's something different.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top