Polaris Riders Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
1,934 Posts
Discussion Starter #1
ok, so ive heard some people talking about the dragging front brakes and all, but what else have you noticed going wrong with our quads? i jsut got a pred about a month ago and would like to know what to expect and what i can prevent on my own
thanks for your ideas
 

·
Premium Member
Joined
·
1,055 Posts
1-rattling plastics
2-brake drag
3-pops a lot
4-whip whacks me in the head w/ stock grab bar)
5-easy to bend handlebars/stem when rolled
6-hard shifting(better with time)
7-runs hot
 

·
Registered
Joined
·
6 Posts
My predator is in the shop for a bad mechanical seal and it sounds like something is dragging on the inside of the cylinder wall. Don't know what that is yet, but I hope to hear from the dealer soon.
 

·
Registered
Joined
·
35 Posts
I've had mine for 6 months now and no problems at all. My front brakes don't even drag and no rattling plastic. As for the handle bars I can't say I replaced the stock ones with the X-Bars and trailtech clamp/computer setup. My whip did seem to be leaning forward alittle so I just bent the whip tab back a little, never hits me in the head. The fan does seem to run often so I used water wetter (helped out alot the fan runs less) and ordered some scoops from modquad www.jetbalstgear.com. (waiting on those to get here). But all I can say is that I've owned many Quads of all makes and this is by far the best and with the least problems. Have fun and race hard.
 

·
Registered
Joined
·
1,934 Posts
Discussion Starter #5
my brakes arent dragging to bad,, plastic is making some noise,, but thats from rolling it,, and my handlebars are straight ist my steering stem that is bending,, anyone know of a good aftermarktet stem?
 

·
Registered
Joined
·
497 Posts
I have had my pred for about three months. Here are the problems I have experienced.
1.) Ball Joints
2.) Plastik
3.) Bolts rattle loose
4.) Frame Broke.

I ride hard and often. MX and trails. I do jump sometimes and have rolled my quad a few times.
 

·
Mostly Harmless
Joined
·
2,544 Posts
I've had no problems other than front brake drag, and the dealer fixed that.

Atenciole, what's wrong with your plastic? And the bolts loose thing. That sounds like a dealer assembly problem to me.

My balljoints are still fine, though I've heard of others having some issues with them. I think it's an isolated thing, just like the brake drag.

Rob
 

·
Registered
Joined
·
1 Posts
I have owned my predator for six months with little to complain about. My plastic does rattle a bit and I had a seal go out on the rear axle. The dealer repaired the seal under warranty.Other than that I have no trouble.
 

·
Registered
Joined
·
394 Posts
My dad bent a shifter fork and lost forth gear. I have only heard of one other pred doin this. I have no problems on mine but the brake drag but I don't have the time to fix that.
 

·
Registered
Joined
·
15 Posts
I don't seem to have any problems with mine at all and I've had it a month (knock on wood) and I weigh over 200lb and have ridden it pretty hard, the thing is awesome.
 

·
Registered
Joined
·
30 Posts
I have had the quad for about 2 months now. The hanger that attaches the nose plastic to the gas tank on the right side has completely broken off. The 2 front bolts that keep the front of the nose on continuously loosen up. I have even tried lock tight and they still walk there way out. I have already lost 5 of the little bolts. Other than that, things are good for me (but the 2 bolts up front are driving me crazy!!!). I almost forgot, the tail light kept and now keeps coming loose after I raced a couple weeks ago.
 

·
Premium Member
Joined
·
1,055 Posts
One other problem I've had with mine that I barely noticed on one of my Preds was when i took off the front plastics I noticed that my fuel pump only had one screw holding it in because the other screws head has broken off by itself!!! So then I looked on my other Preds as well and I noticed on this one only one of the screws was there. Another thing is that i've had problems with the same two bolts that Clears speaks off except on mine I decided to go and put a dab off epoxy along with loctite and it seems to stay there. I also noticed yesterday that one of the bolts that hold on the silencer is not there at all. But this may have been caused by me not tightening the bolts down tight enough. So all in all I would say make sure all the bolts on this sucker are tightened down and inspect it often.
 

·
Premium Member
Joined
·
1,055 Posts
If I had to personify my quad I would say it were the equivalent of a *****.....nice and loose:)
 

·
Registered
Joined
·
119 Posts
well looks like this 4 gear is going to be a prob. hope mine dont break.
 

·
Registered
Joined
·
1,206 Posts
My seat has been rubbing on the top of the airbox and my neutral light works when it wants to. Thats about it for me.
 
1 - 15 of 15 Posts
Top