Polaris Riders Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
The quad starts up fine every time,but when I give it gas it dies.I cleaned the carb,main jet, pilot jet and the passages.I put a new plug in it and made sure it was getting good gas flow.I took the air filter off to see if their was a difference,but still the same.
 

·
Registered
Joined
·
647 Posts
did you check to make sure the gastank vent line was clear??? my little brothers raptor 50 would get clogged with dirt or dirt dobbers and would not let enough fuel flow do to the vaccumm!
 

·
Registered
Joined
·
559 Posts
.


We are assuming the 90 ran perfect a few weeks or even a few months ago, and "no air filter, pipe, carb or CDI changes were applied since then".



Try:


1 - Ensure the factory air filter, clean air filter inner material and proper size air snorkel is on the 90. It's always best to start at base "clean" air filter system - when trouble shooting problems like this.


2 - Install a new spark plug and let it idle for 10 minutes. Remove the plug and tell us its color. It should be slight black / beer bottle brown. If white then you have a mass air leak. Like around the intake or engine crank seals.



Try these 2 things and let us know the results...


thanks.

.
 

·
Registered
Joined
·
223 Posts
Do you have a good flow of gas to the carb? Take the hose off the carb and check it. Check and see if the choke is sticking, I would take the carb apart again and clean and check everything good, the passages are so small it doesnt take much.I would check for air leaks and also do a compression test with a GOOD gauge. Also check the float level to see if its correct. Just a few ideas that might help. Keep us posted.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
1.Good gas flow
2.Changed plug,color of new plug is good black color
3.No resent changes to the motor
4.Right before I had problems boy was riding the quad for about a hour and it was running great.
5.Clean K&N air filter
6.When I took the air filter off and started the quad,it spits gas out the air filter side off the carb?Would this be normal?
7.I am going to clean the carb again with air,I did this last night and it didn't help,but got to try again.
8.THANKS! for the replies,I am glad I found this great site!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
I cleaned the carb for the 3rd time and same thing.
inside the intake where the reeds are there is a red piece of plastic behind the reeds,is it suppose to look like this?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
also while running,gas spits out the carb,the side where the air filter would be,is this normal
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
I found out what the problem was.It was a broken reed,the reed that broke even fliped inside the reed cage.Thanks for all replys and help.Now I got to figure out how to get the piece of reed that is missing out of the motor,maybe I will try a shop vac and get lucky.
 

·
Registered
Joined
·
223 Posts
Probably went through the motor. I would replace them with carbon fiber petals. I think Hetricks should have them. I guess my old eyes still work because the red was a reed stuffer. Glad you found the problem.
 

·
Registered
Joined
·
277 Posts
I purchased a set of carbon fiber reeds from Hetrick Racing last week for $19.95.
 
1 - 12 of 12 Posts
Top