Polaris Riders Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
229 Posts
Discussion Starter #1
Ok, same subject as my post down below. Put the slip on W/B pipe on, ran good but would pop and sputter at high rpm's, not revving all the way out. Put the 157.5 main in, made it even worse, went down to a 152.5, runs better but still won't revv all the way out, pops and sputters at the top of the rpm range. When I got off the bike to look at the pipe I cracked the throttle and I could see flames coming from the disks..... what's the deal with that??? I've got it set up like this, muffler, all 8 disks, then the end cap. No silencer. It seems REALLY loud. what do you guys think?

Thankyou a ton
Sean
 

·
Mostly Harmless
Joined
·
2,544 Posts
Sounds too rich to me... go back to the stock 150 main and see what happens. I don't think jetting changes are required with just the pipe.

Rob
 

·
Registered
Joined
·
229 Posts
Discussion Starter #3
Man this thing is really gettin to me. I put the quite core in to see if that made any difference, id didn't, just makes it sound like a piece of paper flopping around in there.

I've got a question, when you hit the rev limiter, is it like hitting a straight block on the throttle or is it supposed to sputter?
 

·
Registered
Joined
·
453 Posts
Remove the snorkle and grommet from the airbox, see if that helps at all. It shouldn't pop and miss at the rev limit, the rpm's just stop increasing. If removing the snorkle helps and you want to still run it then raise the needle clip one groove and try that to see if it improves at all, go back to the stock main jet and remove the plug over the pilot mixture adjustment screw so that can be adjusted. Set it at 3 turns out from lightly seated and then try adjustments in 1/4 turn increments. This adjustment is for 0 to 1/4 throttle, the needle is for 1/4 to 3/4 and then the main jet takes over to wot.
 

·
Registered
Joined
·
993 Posts
I had to take all the spacers off my pilot to get it to run right, it runs awesome now, way more power than stock. I used rath's pilot, dynojets needle and a 160 main, with raths airbox mod but left the snorkel on and a drop in k&n filter. Now it just revs sraight to the limiter instantly, if I didn't know better I would swear it was a 2-stroke the way it is running now.
 

·
Registered
Joined
·
429 Posts
I've always had mine miss a little at the rev limiter. They retard the spark at the rev limiter so it's gonna happen.
 

·
Registered
Joined
·
434 Posts
Mine spits fire with the WB pipe at the rev limiter. I've got a 155 and the needle in the middle with a direct bolt on filter. Might be a bit rich. Mine also sputters from idle if you just punch it, to about 1500 rpm. I'll be messing with my jetting this thursday.
 

·
Registered
Joined
·
44 Posts
when i installed mine i was dead stock, threw on the pipe with spark arrestor and 6 disk, 7 and it started to sputter.
 
1 - 8 of 8 Posts
Top