Polaris Riders Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
242 Posts
Discussion Starter · #1 ·
There has been no mods to my pedator yet it is fully stock but when i first got it was full of speed everytime i shifted up but now when i go out it seems like everytime i shift up i dont fill the pull or the speed that it had is it because it was just getting broken in or something ?
 

·
Registered
Joined
·
1,935 Posts
had the same feeling with mine, cleaned ut up serviced it and that helped a lot, maybe were getting used to it ripping our asses finally
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #3 ·
ya my friend been telling me to get it serviced but i havent had the time lately with everything going on i think im gunna get it done soon because my friends want to race me because they never raced a predator and im not racing till i fill its 100%.
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #4 ·
vortec how long did it take when yo got the service, like 2 weeks or so
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #5 ·
ok i change the oil add the new oil filter ..... um im gunna greese the joints also im going to clean the air box out to. but i also been hearing a clacking sound in the engine when its idle in nuetral and reason why i hear that ?
 

·
Registered
Joined
·
1,935 Posts
i serviced mine the first time after about a week, i rode a lot then and wanted to do it soon, but i secrewed up and didnt drain all the oil from mine, so i serviced it again a few days ago. since then i service it at least every time i run out a tank of gas.
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #7 ·
alright ya because imbring mine up to get seviced soon. i change the oil yesterday now today im greesiin the joints tighten the chain and cleaning out the air box
 

·
Registered
Joined
·
2,923 Posts
if its getting cooler you guys might want to check your jetting. In the manual it syas to go up to a 155 main, in my area im below 3000 feet.
 

·
Registered
Joined
·
557 Posts
I would suggest to start with cleaning the air filter (replace if stock). If K&N is used and u clean regularly you may be adding too much oil to the filter. with the temp. change it might be time for some rejetting. also consider you may have just gotten use the your predator. Try changing the plug, if rich you may have carbon build up or if lean you may have burned up the electrode.

Dan
 

·
Registered
Joined
·
246 Posts
Hey fellas,
As you bike brakes in you need to jet up things get loose and start to take more fuel.
Jet up adjust your valves you get it back with more ass.
 

·
Registered
Joined
·
3,904 Posts
Ditto on the jetting up and Valves adj........
 

·
Registered
Joined
·
1,935 Posts
whats it take to adj the valves on these babies? mined doing ok now, but i figure im not going to be doing much riding over the winter so i have plenty of time for tear down and adjustment.
 

·
Registered
Joined
·
68 Posts
I have the factory service manual and it looks like a major pain to do a valve job. Be sure to check the clearances on the valves, you might not need to adjust. But I agree, if they are out doing them will make a big diff.

I would suspect the air cleaner unless you have MANY hours. Also check throttle cable adjustment. The winter jets comment is a good point too.

My $0.02
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top