Polaris Riders Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
242 Posts
Discussion Starter · #1 ·
i was out riding yesterday for like 7 hours around the 6 hour we were just sitting talking about where we were gunna go then i went to start my quad up and i hear/felt a click or pop from underneat the seat and it didnt start up then i tryed it for the second time with about like 10 secs in between and it started up perfect and ran great but could there be something wrong and if so what do you think it is . thanks
 

·
Registered
Joined
·
73 Posts
Sounds like a loose battery connection if it just started up like nothing was wrong. I Know on my raptor it gets loose all the time and have to tighten it up after i ride it or jump it for a while. I don't ride this bike very often because it is my wife's and just have not took time to fix the screw.
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #3 ·
ya it just started up but be4 that it was like a click or pop under neath the seat and plus i felt it to ... o ya like 2 hrs be4 that happen i got like a shot of air at my from somewhere on the quad on the right side not knowing what happen there either
 

·
Registered
Joined
·
37 Posts
Mine does that every now and again.Not real sure what it is.I think it feels like back compression or something.Like i said it runs great it only happens once in awhile.Anyone have any ideas on this.Any help would be nice.
 

·
Registered
Joined
·
8 Posts
From your description, I would think that you're talking about a backfire. As long as it doesn't happen too often, I wouldn't worry about it.
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #6 ·
but wheres that burst of air coming from on the right side ?
 
1 - 6 of 6 Posts
Top