Polaris Riders Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
393 Posts
Discussion Starter #1
Ok so I have some what I believe are ground issues with the wireing on my 4X8 utility trailer. Going to try running a ground from the front ground to each of the tail light assembilies due to it being a tilt bed and not sure its getting a good ground. My lights are made my Peterson and have 4 wire insertion holes in the back, two of them are being used for tail lights and brake lights righ now. My question is if I run a ground wire back there can I just stick it through either of the open holes to achieve the ground I am looking for? or is there a better way? Any insight would be appreciated. Thanks.
 

·
Premium Member
Joined
·
5,389 Posts
well, you should be able to ground it to any part of the frame as long as its touching bare metal. I prefer the grounds to be as short as possible.

Edit- nevermind

I think were talking about 2 different things
 

·
Registered
Joined
·
28 Posts
So are the 4 holes 2-live wires and 2-ground wires? I'm sure somewhere it tells you what each of the holes are for. If you have a model number on the light you should be able to look it up online. You could just use a multimeter and test the outputs/continuity.
 

·
Premium Member
Joined
·
393 Posts
Discussion Starter #4
Nope the holes that arent being used are just for more running lights or brake lights there is not special hole for the ground thats why I was wondering if I could still use this as a ground any way? I will have to take a closer look to make sure though, THANKS
 

·
Premium Member
Joined
·
393 Posts
Discussion Starter #5
So I checked the light again and there is actually 4 holes on each side of the back for wiring and one side is the running lights and the other is the brake. None of which says ground. When I looked up the light online it claims that it "grounds through 1/4” mounting studs". So being a tilt I am feeling like the ground is not a solid one and is being broke up due to the tilt part could I just run a wire from the original ground to the some where on the trailer behind the tilt part and be fine?? Or is this not a good idea??
 

·
Premium Member
Joined
·
393 Posts
Discussion Starter #7
Thanks Superman I will try that!!
 
1 - 7 of 7 Posts
Top