Polaris Riders Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
1,055 Posts
Discussion Starter #1
Here's my problem. After I switched to a clamp on filter I noticed that in first gear i cant get to the top of my first gear cuz it starts to "burp". Its not like when it would pop cuz of jetting but instead it just seriously burps and loses power. Its as if Im hitting my rev limiter which I am not. What is going on? Second third fourth and fifth are still normal but its just first. Please help. My dealer says that its probably the turbulence from the filter. He says i need something inbetween the filter and the carb to straighten the air out. What do I do. Thanks.
 

·
Registered
Joined
·
1,103 Posts
John, did you check your idle-1/4 throttle jetting...pilot screw/jet adjustment area? I found my pilot screw out 4 turns from the factory. With the TMX carbs normally anything after 3 turns out wasn't effecting anything. I'd double check that plug color.
 

·
Premium Member
Joined
·
1,055 Posts
Discussion Starter #3
My plug color is fine. Im at a 167.5 main and a 50 pilot. I'll have to check the pilot screw.
 

·
Mostly Harmless
Joined
·
2,544 Posts
By pilot screw are you talking about the Air-Fuel screw?

If the air is turbulent, there's no reason somebody couldn't build an "airfoil" to fit between the filter and the carb.

Rob
 

·
Premium Member
Joined
·
1,055 Posts
Discussion Starter #5
Well since i didnt wanna mess around with it all i decided to ditch the clamp on idea and went to the cycle center and bought myself an oval filter for a yami. I used to stock intake snorkel and removed the whole airbox and i mounted the oval filter to the part of the snorkel that used to mount to the airbox lid. Works so much better. thanks guys.
 
1 - 5 of 5 Posts
Top