Stumped on a 04 predator 90 - Polaris Riders
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 03-31-2019, 11:31 PM Thread Starter
Senior Member
 
runnunwithagun's Avatar
 
Join Date: May 2006
Location: abbotsford
Posts: 269
Stumped on a 04 predator 90

Wow it's been a long time since I've been on here. Well me and my son got a pred 90 a bit ago and now after sitting for the winter I can't get it to start at all. I've got fresh gas, clean air filter, carb is squeaky clean, getting decent spark, 95 psi compression. Fuel is getting to the engine, plug is wet after trying to start. But it's giving me no hint of trying to fire. Where do I turn next guys? This lil bugger has me puzzled
runnunwithagun is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris Riders forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome