Tried everything, still won't fire.. - Polaris Riders
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 03-19-2017, 06:07 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Posts: 1
Tried everything, still won't fire..

Hey guys; So I've been trying to get this predator to start.. Rode beautifully for a bit, an one night just died out... I've checked the Pistons, did the timing, cam, carb clean/adjusted cleared the lines, ran new gas, an even cleaned the combustion chamber. It still refuses to fire. Spark is fine as well. There's plenty of compression, yet it won't start unless I pop start it. Even then it wants to dog out right away.. any ideas?
Nathan Levi Burns is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-22-2017, 08:30 AM
Junior Member
 
Join Date: Mar 2017
Posts: 1
Sounds like a fuel delivery or fuel pressure problem.
tropical nuts is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris Riders forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome